Назад Вперед

Gentoo: limits

Автор: Bobspct от 25 августа 2016, посмотрело: 44

Установить лимиты open files в Gentoo
 
Отредактировать файл /etc/security/limits.conf: 

	*               hard    nofile          65535
	*               soft    nofile          65535
	

Категория: Linux / Gentoo

 

Gentoo: Кто требует определенный пакет

Автор: Bobspct от 25 августа 2016, посмотрело: 24

Если нужно узнать, кто "хочет" определенный пакет в Gentoo, надо выполнить команду 
equery depends пакет
 
Например:
 

	equery depends cairo
	 * These packages depend on cairo:
	dev-java/oracle-jre-bin-1.8.0.102 (javafx ? x11-libs/cairo)
	dev-libs/gobject-introspection-1.46.0 (cairo ? x11-libs/cairo[glib])
	gnome-base/librsvg-2.40.15 (>=x11-libs/cairo-1.12.14-r4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
	media-libs/harfbuzz-1.2.7 (cairo ? x11-libs/cairo)
	net-analyzer/ettercap-0.8.2 (gtk ? x11-libs/cairo)
	x11-libs/pango-1.38.1 (>=x11-libs/cairo-1.12.14-r4[X?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]) 
	
	

Категория: Linux / Gentoo

 

Centos: ulimit open_files_limit не меняется

Автор: Bobspct от 6 апреля 2016, посмотрело: 320

Если в Centos 7 не меняется ulimit -n после внесения изменений в limits.conf для какого-либо из сервисов, то в юните systemd надо добавить строку в секцию [Service]:
LimitNOFILE=16384
 
Например:

	cat /etc/systemd/system/multi-user.target.wants/rabbitmq-server.service 
	[Unit]
	Description=RabbitMQ broker
	After=syslog.target network.target
	[Service]
	LimitNOFILE=16384
	Type=notify
	User=rabbitmq
	Group=rabbitmq
	WorkingDirectory=/var/lib/rabbitmq
	ExecStart=/usr/lib/rabbitmq/bin/rabbitmq-server
	ExecStop=/usr/lib/rabbitmq/bin/rabbitmqctl stop
	[Install]
	WantedBy=multi-user.target 
	
 
После этого выполнить

systemctl daemon-reload 

Категория: Linux

 

Как обновить timezone в Gentoo

Автор: Bobspct от 7 ноября 2014, посмотрело: 10 101

Да, в общем все легко и просто делается
Сначала отсинхронизируем репозитарий, потом установим новую версию таймзон. 

	# emerge --sync
	# emerge timezone-data
	
Будьте внимательны, если вы давно не обновляли систему, то portage может обновиться до EAPI 5 и надо будет повозиться с новыми профилями компиляции.

Категория: Linux

 

Копирование данных с помощью архивации через SSH

Автор: Bobspct от 22 июля 2014, посмотрело: 16 002

tar cvf - /InputDir | ssh user@server.tld 'cd /StoreDir ; tar xf -'

или

tar zcvf - /InputDir | ssh user@server.tld 'cat > /StoreDir/backup.tar.gz'

Категория: Linux

 

/usr/bin/ssh-copy-id: ERROR: No identities found

Автор: Bobspct от 22 июля 2014, посмотрело: 10 433

Если произошла такая фигня, то:

eval `ssh-agent`

ssh-add

ssh-copy-id user@example.com

Категория: Linux

 

Iptables, ошибка "The state match is obsolete. Use conntrack instead"

Автор: Bobspct от 21 января 2013, посмотрело: 457 507

В messages возникла ошибка при запуске iptables: "The state match is obsolete. Use conntrack instead."

 

Лечится заменой mod state на conntrack --ctstate

 

-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT 

Меняем на

-A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT

 

В случае с ferm

 mod state state (ESTABLISHED RELATED) ACCEPT;

на

mod conntrack ctstate (ESTABLISHED RELATED) ACCEPT;

Категория: Linux

 

Обновление gcc в Gentoo

Автор: Bobspct от 25 сентября 2012, посмотрело: 115 073

emerge glibc gcc

#(смотрим версии)

gcc-config -l   

gcc-config i686-pc-linux-gnu-*.*.* 

#Если не пошло само - запускаем:

#fix_libtool_files.sh *.*.* (версия gcc что стояла до этого)
emerge -e system
emerge -e world

Категория: Linux / Gentoo

 

Настройка Samba через браузер при помощи SWAT

Автор: Bobspct от 13 января 2012, посмотрело: 17 460

Понадобилось мне вдруг настроить в Samba заливку файлов в каталог под определенным пользователем и с определенными правами на сайт. Покопавшись в конфиге Samba я как-то не углядел и не нашел ничего подобного, хотя знал, что такая штука там есть. Решил попробовать поставить swat и найти эти параметры там.

Категория: Linux / Gentoo

 

Проблема с date.timezone в PHP 5.3

Автор: Bobspct от 13 января 2012, посмотрело: 9 365

После перехода с PHP 5.2 на 5.3 столкнулся с проблемой временной зоны.

Возникали ошибки вида:

Warning: Unknown: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set () function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSK/4.0/no DST' instead in...

Категория: Linux

 
Назад Вперед